ANS-1405 · DéVELOPPEMENT SUITESCRIPT
Comment résoudre l’erreur de limite de caractères « custrecord_ste_backend_inv_error_details » dans NetSuite ?
Résolvez l'erreur NetSuite liée au fait que le champ « custrecord_ste_backend_inv_error_details » dépasse sa limite de 4 000 caractères lors de la création d'une commande client ou d'une facture, en activant les formulaires en ligne et en configurant les rôles de déploiement des scripts.
Solution courte
L'erreur « Le champ custrecord_ste_backend_inv_error_details contenait plus que le nombre maximal (4 000) de caractères autorisés » sur les commandes client ou les factures est résolue en activant la fonctionnalité « Formulaires en ligne » sous Configuration > Société > Activer les fonctionnalités > onglet CRM. De plus, ajoutez le rôle « Utilisateur de formulaires en ligne » à l’audience « Rôles externes » du déploiement du script customdeploy_ste_sl_backend_admin.
Scénario
Les utilisateurs rencontrent une erreur de script inattendue lors de la création de commandes client ou de factures dans NetSuite. Le message d'erreur indique que le champ « custrecord_ste_backend_inv_error_details » a dépassé sa limite maximale autorisée de 4 000 caractères. Ce problème persiste même après avoir tenté de désinstaller d'autres scripts, d'utiliser des formulaires standard ou de mettre à jour le module SuiteTax Engine.
Solution
Pour résoudre cette erreur, procédez comme suit :
Accédez à Configuration > Société > Activer les fonctionnalités > onglet CRM.
Sous Marketing, activez la fonctionnalité : Formulaires en ligne. Cliquez sur Enregistrer.
Accédez à Personnalisation > Scripts > Déploiements de scripts.
Recherchez « customdeploy_ste_sl_backend_admin » et cliquez sur « Modifier ».
Sous l’onglet « Audience », dans « Rôles externes », ajoutez « Utilisateur de formulaire en ligne ».
Enregistrez le déploiement du script.
Support expert NetSuite
Besoin d’aide pour cet enjeu NetSuite ?
Accompagnement-conseil et configuration pour Développement SuiteScript
